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Sheet 1: Manager

EpiData Manager
Task Linux Mac Win Win Notes

Start Program, click Help -> Copy Version
Information.

EpiData Manager:
(2017/01/15 -
17:04:36)

EpiData Manager:
(2017/01/13 -

10:17:38)

EpiData Manager:
(2017/01/13 –

13:34:12)

Paste copied values in the appropriate OS
column.

Program Version:
4.0.0.95 [TRUNK]
r1371

Program Version:
4.0.0.95 [TRUNK]

r1371

Program Version:
4.0.0.95 [TRUNK]

r1371

Core version:
4.0.0.0 r1344

Core version:
4.0.0.0 r1344

Core version:
4.0.0.0 r1344

FPC Version: 3.0.0
FPC Version:

3.0.0
FPC Version:

3.0.0

Platform:
i386-Darwin

Platform:
i386-Win32

Platform:
x86_64-win64

Open/Save/Close
Task Linux Mac Win Win Notes

Create new project from “File->New” ok ok ok

Close project from “File->Close Project” ok ok ok

Create new project with shortcut ok ok ok

Close project with shortcut ok ok ok

Open project “sample.epx” from
“File->Open” ok ok ok

Open recent project “sample.epx” from
“File->Open Recent->...” ok ok ok

Open project “sample.epx” with shortcut ok ok ok

Open recent project with shortcut ok ok ok

Save project using “File->Save Project” ok ok ok

Save project using shortcut ok ok ok

Save project as, using “File->Save Project
As” to a random filename. ok ok ok

Save project as, using shortcut ok ok ok

Close project ok ok ok

Preferences
Task Linux Mac Win Win Notes

Open preferences with Edit->Preferences
(on Mac: “epidatamanager->Preferences”) ok ok ok

Close preferences ok ok ok

Open preferences with shortcut ok ok ok

Click all items on the treelist without other
interaction ok ok ok

når jeg har trykket ok
herefter, så kan jeg lige
som de forrige gange
på mac, ikke åbne
preferences igen

In the following tests marked with itallic
font, it is assumed that preferences are
opened anew each time, and clicked OK
at the end. ok ok

hverken alm vej eller
genvej virker

Select “General” and untick all check-
options ok ok
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Select “Path”, change 'default data folder'
and 'tutorial folder' to something random.
Delete content of 'Web tutorial URL' ok ok

Select “Field Definitions”. Change field
length: Integer = 2, Float = 3.1, String = 10.
Change Field prefix to 'F' ok ok

Select “Visual design”. Change positions:
Field pos = 200, Label pos = 100. Change
vertical distance: Field-Field = 20,
Field-Label = 10, Label-Label = 20. Remove
checks in all snapping optiong. ok ok

Select “Fonts”. Choose a random font for
each possible setting. Then choose a
random colour for all fonts. ok ok

Select “Statusbar”. Untick all check options. ok ok

Select “Export”. Untick all check options. ok ok

Select “Stata”. Untick all check options. ok ok

Select “CSV”. Change all separators to
random charactes (must be unique). Untick
all check options. ok ok

Select “SPSS”. Change delimiter to random
character. Untick all check options. ok ok

Select “DDI”. Change language to
something random. Change all separators
to random characters (must be unique).
Untick all check options. ok ok

Select “EPX”. Untick all check options. ok ok

Select “Project Defaults”. Observe
automatically selects “Backup”! Change
'timed recovery' to 20. Untick all check
options. ok ok

Select “Auto increment”. Change starting
increment value to 10. ok ok

Select “Display of Fields”. Untick all check
options. ok ok

Open preferences, click restore defaults,
click OK. ok ok

Study Information
Task Linux Mac Win Win Notes

Start new project. Observe welcome page
with short description. Click 'close page'. ok ok ok

Fill out 'Title' and 'Abstract' with random text. ok ok ok

Select “Coverage” page. ok ok ok

Fill out 'Geographical', 'Data time coverage',
'Population' and “Unit of observation' with
random content.

kan ikke vælge en
dato fra kalender -
kun taste manuelt ok ok

Select “Description” page. ok ok ok

Fill out 'Keywords', 'Purpose', 'Citation' and
'Design' with random text. ok ok ok

Select “Ownership” ok ok ok

Fill out 'Organization', 'Author' and 'Rights'
with random text. ok ok ok

Fill out 'Agency' with 'www.epidata.dk' ok ok ok

Select “Funding” page and fill page with
random text. ok ok ok

Select “Version Details” page. ok ok ok

Fill out 'Identifier' with random text and
change version number = 10. ok ok ok

Save project to a random file. ok ok ok

Close project and re-open project. ok ok ok

Go through “Title” -> “Version Details” and
verify that content is the same as previously
saved. ok ok ok
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Close project ok ok ok

Designer
Task Linux Mac Win Win Notes

Start new project. Select “Dataform 1” ok ok ok

Click 'Integer' field button and click
somewhere on the form. ok ok ok

Observe “Field Properties” window
appearing and is focused. 'Name' = V1 ok ok ok

Navn er F1 i stedet for
V

Focus “Main” and use shortcut to create
'Integer' field. ok ok ok

Ved shortcut skriver den
automatisk
genvejstasten (f.eks.
"2") som tekst i label

Observe: New field placed slightly below
first field, focus changed to “Field
Properties”, “Field Properties” is updated
with new 'name' = V2. ok ok ok

^gælder ikke genvej til
'interger' (1)

Repeat above in Italic but with the following
field types: Float, String, Date, Time,
AutoDate (dmy), AutoTime, Boolean,
AutoIncrement
Observe: 'Name' should follow incremental
naming (eg. V3+V4 for Float, V5+V6 for
String, etc), When using mouse to place
fields, the field is placed at the position of
the mouse cursor, whereas using the
shortcut fields are placed slightly below the
field in the lowest part of the screen. ok ok ok

Save project to a random file. ok ok ok

Close project and re-open project. ok ok ok

Observe: Field are placed in the same
positions as previously created. ok ok ok

Close project ok ok ok

Start new project. Select “Dataform 1” ok ok ok

Create fields Integer (V1), Float (V2), String
(V3), Date (V4), Time (V5). ok ok ok

Select V1 using mouse, observe 'handles'
shown. ok ok ok

Click and hold (CnH) left-mouse button
(LMB) on V1, drag field to the right and
release mouse.
Observe: dotted lines while dragging, Field
is placed where mouse was released.

ingen dotted line -
kun 'handles' - kan

ikke se hvor jeg
trækker hen ok ok

Press 'Shift' key and click in sequence on
V2, V3, V4, V5.
Observe: Handles disappear, but marking
on V1 -> V5. ok ok

CnH LMB on V1, then drag selection down,
but while all fields are within visible are.
Observe: dotted lines for all fields while
dragging, field are placed where mouse was
released.

ok - ingen dotted
lines ok ok

Close project, accept not to save content. ok ok ok

Start new project. Select “Dataform 1” ok ok ok

Click 'Heading' button and click somewhere
on the form. ok ok ok

Observe: “Heading Properties” window
appearing and is focused. 'Name' = H1. ok ok ok

Focus “Main” and use shortcut to create
'Heading'

ok - samme
problem med

automatisk "6" som
label ok ok
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Observe: New heading placed slightly below
first heading, focus remains on “Main”,
“Heading Properties” is updated with new
'name' = H2. ok ok ok

Click 'Section' button and CnH LMB while
dragging a square.
Observe: dotted lines indicating area,
section is created with the size of the dotted
lines. ok ok ok

Close project, accept not to save content. ok ok ok

ok ok

Open project “sample.epx” from
“File->Open” ok ok ok

Select field “C3: Year” in “Calculated fields”
section, right-click the field and select Copy
(or use the shortcut) ok ok ok

Right-click in the section below “String
fields:” and select “Paste”. ok ok ok

Save project as, using “File->Save Project
As” or use shortcut to a random filename. ok ok ok

Close project ok ok ok

Field Propeties
Task Linux Mac Win Win Notes

Start new project. Select “Dataform 1” ok ok ok

Create fields Integer (V1), Float (V2), String
(V3), Date (V4), Time (V5). ok ok ok

Select V1. Focus “Field Properties” and
select 'Name'. ok ok ok

Basic Page:
Name = 'V10', Question = 'Test', Length =
'3', Range = '10 – 200'
Click Apply and Observe:
In designer, the question text will appear on
the left side of the field, the width of the field
has expanded. ok ok ok

Extended Page:
Entry Mode = 'Must Enter',
ConfirmFieldEntry = checked,
RepeatLastValue = checked, Default value
= '100', AddLeadingZeros = checked. ok ok ok

Jumps Page:
Click '+', Jump Value = 10, GoToField = V2,
Reset Value = System missing ok ok ok

Calculate Page:
Check 'combine fields'. Result = V3, Field 1
= V10, Field 2 = V2, Field 3 = V4 ok ok ok

Notest Page:
Type in random text. Click Close. ok ok ok

Save project to a random file. ok ok ok

Close project and re-open project. ok ok ok

Observe: Fields are placed in the same
positions and with same attributes as given
above. ok ok ok

Close project ok ok ok

Heading Propeties
Task Linux Mac Win Win Notes

Start new project. Select “Dataform 1” ok ok ok

Create 3 headings (H1, H2, H3). ok ok ok

Select H1, Focus 'Heading Properties'. ok ok ok
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Change properties:
Name = H10, Text = 'Sample text',
HeadingType = 'Heading 1'.
Click Apply and Observe:
Heading text changed, size of 'Sample text'
increases. ok ok ok

Save project to a random file. ok ok ok

Close project and re-open project. ok ok ok

Observe: Headings are placed in the same
positions and with same attributes as given
above. ok ok ok

Close project ok

Section Propeties
Task Linux Mac Win Win Notes

Start new project. Select “Dataform 1” ok ok ok

Create 3 sections (S1, S2, S3) ok ok ok

Select S1, Focus Section Properties ok ok ok

Change properties:
Name = H10, Caption = 'Section A'.
Click apply and Observe:
Section has 'Section A' applied. ok ok ok

Save project to a random file. ok ok ok

Close project and re-open project. ok ok ok

Observe: Sections are placed in the same
positions and with same attributes as given
above. ok ok ok

Close project ok ok ok

Define Key
Task Linux Mac Win Win Notes

Start new project. Select “Dataform 1” ok ok ok

Create 5 Integer fields (V1 -> V5) ok ok ok

Click Dataform -> Define Key: Observe no
selected fields ok ok ok

Click “+”, observe new line with no selected
item in drop-down list ok ok ok

Click drop-down list, select V1. Observe
V1->V5 in list. ok ok ok

Click “+”, observe new line with no selected
item in drop-down list ok ok ok

Click drop-down list, select V2: Observe V1
missing from items. ok ok ok

Click drop-down list for V1: Observe V2
missing from items. ok ok ok

Click “+”, observe new line with no selected
item in drop-down list ok ok ok

Click drop-down list, select V3: Observe V1,
V2 missing from items. ok ok ok

Click drop-down list for V1: Observe V2, V3
missing from items. ok ok ok

Click “-” right of V3: Observe whole line is
removed. ok ok ok

Click drop-down list for V1: Observe V2
missing from items, but V3 present again. ok ok ok

Click OK. Observe window closes and focus
is back on Main window. ok ok ok

Save project to a random file. ok ok ok

Close project and re-open project. ok ok ok
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Click Dataform -> Define Key: Observe two
line with select V1 and V2. ok ok ok

Close project ok ok ok

Relational Dataforms
Task Linux Mac Win Win Notes

Start new project. Select “Dataform 1” ok ok ok

Create 5 Integer fields (V1 -> V5) ok ok ok

Create key with fields V1,V2 ok ok ok

Above the project tree, press “+”.
Observe:
New dataform is created as a 'child' of
“Dataform 1”. Dataform caption = “Dataform
2”. “Dataform 2“ is selected”. New dataform
contains 2 fields (V1, V2). ok ok ok

Select V1 and open field properties.
Observe: No properties can be changed
(except for adding notes). ok ok ok

Select V1 & V2. Move fields to a new
random location.
Observe: This is possible and fields move
as if they were “normal” fields ok ok ok

Create 3 additional integer fields (S3 -> S5).
Observe: The naming should be S3, S4 and
S5 og the newly created fields. ok ok ok

Select V3 and open field properties.
Observer: Properties may be changed. ok ok ok

Select “Dataform 1”, then select V1, open
and select field properties. ok ok ok

Change properties: Length = 3. ok ok ok

Select “Dataform 2“, then select V1, open
field properties.
Observe: Length of V1 has change to 3. ok ok ok

Save project to a random file. ok ok ok

Close project and re-open project. ok ok ok

Observe: Dataforms are present af created
above. Dataform 1 contains fields V1 -> V5.
Dataform contains fields V1 -> V5. Length =
3 for V1 on both dataforms. ok ok ok

Select “Dataform 1”, click “+” above the
project tree.
Observe “Dataform 3” is created on the
same level as “Dataform 2”. ok ok ok

Select “Dataform 1” again, open dataform
properties. Select “After Record” page. ok ok ok

Click “+”, observe new line with selected
with “Dataform 2”. ok ok ok

Change property “Go to Dataform” to
“Dataform 3” ok ok ok

Click “Apply”, focus Main window, select
field V5 and open field properties. ok ok ok

On Field Properties window, select “Relate”
page. ok ok ok

Click “+”, observe new line with “Go To
Dataform” selected with “Dataform 2” and
empty “Relate Value”. ok ok ok

Change properties: “Relate Value” = 1. Click
Apply. ok ok ok

Save project to a random file. Close project
and re-open project. ok ok ok

Observe: Dataforms are present as created
above. On “Dataform 1” field V5 has
“Relate” page as above. On properties form
for “Dataform 1”, “After Record” has same
entries as above. ok ok ok
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Close project ok ok ok

Value Labels
Task Linux Mac Win Win Notes

Start new project. Select “Dataform 1” ok ok ok

Create 3 fields, Integer (V1), Float (V2),
String (V3) ok ok ok

Select V1, open field properties and select
page “Basic” ok ok ok

Observe in group “Valuelabel”, button is
named “New” ok ok ok

Click “New”.
Observe: New window appear with caption
“Field Valuelabel Editor”. “Valuelabel Name”
= “_V1”. A single line with “Value” = 1, Label
has no value. Focus is on the entry box
below “Label” column. ok ok ok

Add random text to the label and press
“Enter/Return” ok ok ok

Click “+”, observe new line with “Value” = 2
and focus is on entry box in label column. ok ok ok

Add random text to the label and press
“Enter/Return” ok ok ok

Click “OK”. Observe in group “Valuelabel”:
Drop-down box has changed to “_V1”.
Button to the right caption changed to “Edit” ok ok ok

Click “Apply”. Observe: On main window,
beside the field (V1) the text “_V1” appears
in a green colour. ok ok ok

Select V2, open field properties and select
page “Basic” ok ok ok

Observe in group “Valuelabel”, button is
named “New” ok ok ok

Click “New”.
Observe: New window appear with caption
“Field Valuelabel Editor”. “Valuelabel Name”
= “_V2”. A single line with “Value” = 1, Label
has no value. Focus is on the entry box
below “Label” column. ok ok ok

Add random text to the label and press
“Enter/Return” ok ok ok

Double-click the “1” in the “Value” column.
Change the value to “0,5” and end editing
by pressing Enter/Return. ok ok ok

Click “+”, observe new line with “Value” = 1
and focus is on entry box in label column. ok ok ok

Add random text to the label and press
“Enter/Return” ok ok ok

Click “OK”. Observe in group “Valuelabel”:
Drop-down box has changed to “_V2”.
Button to the right caption changed to “Edit” ok ok ok

Click “Apply”. Observe: On main window,
beside the field (V2) the text “_V2” appears
in a green colour. ok ok ok

Select V3, open field properties and select
page “Basic” ok ok ok

Change properties: Length = 3 ok ok ok

Observe in group “Valuelabel”, button is
named “New” ok ok ok

Click “New”.
Observe: New window appear with caption
“Field Valuelabel Editor”. “Valuelabel Name”
= “_V3”. A single line with empty “Value”,
empty “Label”. Focus is on the entry box
below “Label” column. ok ok ok
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Add random text to the label and press
“Enter/Return” ok ok ok

Double-click the box in the “Value” column.
Change the value to “AAA” and end editing
by pressing Enter/Return. ok ok ok

Click “+”, observe new line with empty
“Value” and focus is on entry box in label
column. ok ok ok

Add random text to the label and press
“Enter/Return” ok ok ok

Double-click the box in the “Value” column.
Change the value to “BBB” and end editing
by pressing Enter/Return. ok ok ok

Click “OK”. Observe in group “Valuelabel”:
Drop-down box has changed to “_V3”.
Button to the right caption changed to “Edit” ok ok ok

Click “Apply”. Observe: On main window,
beside the field (V3) the text “_V3” appears
in a green colour. ok ok ok

Save project to a random file. Close project
and re-open project. ok ok ok

Observe: Fields V1 -> V3 have the same
valuelabels listed _V1 -> _V3 both on main
window, but also on Field properties
window. ok ok ok

Open Valuelabel Editor (Project -> Value
labels... | Project Details -> Value labels... |
Shortcut).
Observe: New window opens, Tree on left
contains _V1, _V2, _V3 with associated
icons. ok ok ok

Click “_V1” and observe: On right panel,
previously entered values for appear. ok ok ok

Repeat the click above, but with _V2 and
_V3 ok ok ok

Close project ok ok ok

Simple Password
Task Linux Mac Win Win Notes

Start new project. Select “Dataform 1” ok ok ok

Create 3 fields, Integer (V1), Float (V2),
String (V3) ok ok ok

Click “User Access” -> “Simple Password”
-> “Set Password”. Observe: New window
appear with caption “Set Project Password” ok ok ok

Enter a random password, then press Enter.
Observe: a new window appear with text:
“Re-enter Password” ok ok ok

Repeat random password, then press Enter.
Observe: a new window appear with text:
Password successfully set! ok ok ok

Press “OK”. ok ok ok

Save project to a random file. Close project
and re-open project.
Observe: upon opening file a window
appear with caption “Project Password”. ok ok ok

Enter a new random password (must be
different from the real password), then press
Enter. ok ok ok

Observe: Same window appear, asking for a
password again!
Repeat entering an incorrect password 2x. ok ok ok

Observe: After last incorrect password a
new window appear witht the text “Unable to
open the file: .... Invalid password ok ok ok

Click “OK” and re-open project once more.
Enter correct password. ok ok ok
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Observe: Project is loaded correctly with the
same fields V1 -> V3 ok ok ok

Close project ok ok ok

Import data
Task Linux Mac Win Win Notes

Start new project. Select “Dataform 1” ok ok ok

Click “File” -> “Import file...”. Observe: Open
file window appear. ok ok ok

Select file “bromar.rec” and click “Open”.
Observe:
New window appear with caption “Add
structure/Import Data”.
In group “Repeated Field Names” selected
option is “Rename”.
In group “Releated Value Labels” selected
option is “Keep First, drop all other”
In file list, “Structure” AND “Data” columns
are checked. ok ok ok

Click OK. Observe: ok ok ok

10 fields: (id, sex, error, km, kmgrp, age,
agegrp, dectime, decgrp, runok) ok ok ok

Dataform Caption: “Marathon data - 1995
across bridges from Funen and” ok ok ok

Valuelabels: (kmlbl [6 items], declbl [4
items], yn [2 items]) ok ok ok

Records: 4027 ok ok ok

Close project, accept not to save content. ok ok ok

ok ok

Click “File” -> “Import file...”.
Observe: A new project start and the open
file window appear. ok ok ok

Select file “sample.csv” and click “Open”.
Once “Add structure/Import Data” window
appear, click “OK”. Observe: ok ok ok

Observe: On dataform 1, 33 fields are
placed: (I1, F1, I2, VL1, VL2, VL3, D1, D2,
D3, T1, A1, A2, A3, A4, A5, O1, O2, O3,
O4, C1, C2, C3, C4, S1, S2, S3, J1, J2, J3,
M1, M2, M3, VLAST) ok ok ok

In status bar: Records: 12 ok ok ok

Open Data browser (“Dataform” -> “Browse
Data”) and validate:
I1[8] = 90123456
F1[4] = 4567.8901
D2[12] = 01-13-2011
S1[4] = 中文 ok ok ok

Close project, accept not to save content. ok ok ok

Align
Task Linux Mac Win Win Notes

Open project “align.epx” ok ok ok

Open Alignmen window from “Edit” ->
“Align” -> “Alignment...” ok ok ok

Observe: A new window with caption
“Alignment” appears. ok ok ok

Without closing Aligment window, select all
5 fields. ok ok ok

On the alignmentform click “Align Left”
button. Observe: All fields align with the top
field (V1) on the left side. ok ok ok

On the alignmentform click “Center
Vertically”. Observe: All fields centers with
V3 un-moved. ok ok ok
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On the alignmentform click “Align Right”.
Observe: All fields align with V3 on the right
side. ok ok ok

On the alignmentform click “Even Horizontal
Distance” button. Observe: All fields spread
out in order left to right: V3, V4, V2, V5, V1. ok ok ok

Close project, accept not to save content. ok ok ok

Export
Task Linux Mac Win Win Notes

Open project “Clinical Example.epx” ok ok ok

Open Export window (Export button or Tools
-> Export) ok ok ok

Observe:
- A new window with caption “Export...”
appears.
- Type = Stata, “Create Export Report” is
checked.
- On the dataform tree all dataforms are
selected (“Start Entry Here”,
“Person and...”, etc.)
- Export fields: All fields are selected.
- Dataform Options: “All Records” selected. ok ok ok

Click “Person and Basic Data” ok ok ok

Observe:
- All fields are allready selected.
- Filename = Clinical Example_<Dataform
Caption>.dta ok ok ok

Repeat the 2 above, with “Type of Disease”,
“Visit at Clinic”, “Lab Result” ok ok ok

Close Export window by clicking “Cancel” ok ok ok

Open Export window ok ok ok

Change type to CSV
Change export folder to temporary folder ok ok ok

Observe: Filename changes extention to
.csv ok ok ok

Click “OK” and observe:
- A dialog window appears with “Export
Succeeded” (Click OK to proceed)
- A report information regarding executed
export. ok ok ok

Repeat above in Italic but Change the type
each time to:
Stata, SPSS, DDI, EPX

ok - SPSS vil
overskrive csv ok ok

Open Export window ok ok ok

Change type to EPX
Change export folder to temporary folder
In “export options” check the “Export to
single file” ok ok ok

Observe:
- The project tree is reset (no dataforms are
checked)
- Filename is changed to: Clinical
Example_<todays date>.epx ok ok ok

Make a check in project tree for “Lab Result”
and observe:
- “Lab result”, “Visit at Clinic” and “Start
Entry Here” have all become checked ok ok ok

Click “OK” and observe:
- A dialog window appears with “Export
Succeeded” (Click OK to proceed)
- A report information regarding executed
export. ok ok ok
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Close the report AND close the project. ok ok ok

Open the newly created EPX file from File
-> Recents ok ok ok

A warning may be displayed, asking to load
the original file. Ensure that the new file is
loaded, not the original. ok ok ok

Observe:
- The new file only contains the seleted
dataforms from export ok ok ok

Close project ok ok ok

User Access
Task Linux Mac Win Win Notes

Start new project. Select “Dataform 1” ok ok ok

Create 3 fields, Integer (V1), Float (V2),
String (V3) ok ok ok

Click “User Access” -> “Extended Access”
-> “Add User/Group Administration”.
Observe: New window appear with a
warning text. Press OK. ok ok ok

New Windows will appear with caption “User
Properties” ok ok ok

Enter “admin” in login and press Enter.
Enter a random password and press Enter.
Observe a new window appears with title
“Set User Password”. ok ok ok

Repeat password and press Enter.
Observe: “Set User Password” disappers. ok ok ok

Click OK. Observe a “save file as” dialog
appears. ok ok ok

Save project to a random file and observe
an information dialog appears with
“User/Group Administration successfully
added”. Click OK ok ok ok

A new dialog appear with “password
required for....”. User “admin” and chosen
password to re-open the file. Observe: ok ok ok

Observe: Project is loaded correctly with the
same fields V1 -> V3 ok ok ok

Observe: In Statubar a panel with “login:
admin” is present ok ok ok

Close project ok ok ok

All password entries for users in the file
“Clinical Example Admin.epx” are
“ostemad”. Use that password whenever
a login is required. ok ok ok

Open project “Clinical Example admin.epx” ok ok ok

Observe “password required...” dialog
appears. Use “admin” as login and press
OK. ok ok ok

Open Define Group: “User Access” ->
“Extended Access” -> “Define Group” ok ok ok

Observe
- “Define Groups” windows appears
- 7 Groups defined with following properties:
* Admins: D, De, T, G, U, P, E, X, R
* Password Admins: P
* Data Exporters: E
* Translators: T
* Data Entry Personel, Lab Workers,
Regular Data Entry: (none) ok ok ok
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Observe: on left panel “Admins” is selected”,
on right side only “admin” is selected. ok ok ok

On left panel, select “Password Admins”.
Observe on right side “admin” is implicitly
selected and “pwadmin” is explicitly
selected. ok ok ok

Click checkbox for “admin” and observe that
no change was made. ok ok ok

Click checkbox for “pwadmin” and observe
that it is now deselected. Click again to
select it again. ok ok ok

On left panel, select “Data Exporters”.
Observe on right side “admin” is implicitly
selected and “exporter” is explicitly selected. ok ok ok

On left panel, select “Translators”. Observe
on right side “admin” is implicitly selected
and “translator” is explicitly selected. ok ok ok

On left panel, select “Data Entry Personel”.
Observe on right side “admin” is implicitly
selected and no other users are explicitly
selected. ok ok ok

On left panel, select “Lab Workers”.
Observe on right side “admin” is implicitly
selected and “labrat” is explicitly selected. ok ok ok

On left panel, select “Regular Data Entry”.
Observe on right side “admin” is implicitly
selected and “dataentry” is explicitly
selected. ok ok ok

Close “Define Groups” ok ok ok

Open “Define Users”: “User Access” ->
“Extended Access” -> “Define Users” ok ok ok

Observe: 6 users exists with the login
names “admin”, “translator”, “exporter”,
“pwadmin”, “labrat” and “dataentry” ok ok ok

Close “Define Users” ok ok ok

Open “Define Entry Rights”: “User Access”
-> “Extended Access” -> “Define Entry
Rights” ok ok ok

Observe: The same structure of related
datasets on the left panel. The “Start Entry
Here” is selected. The right hand side has
the same structure as in “Define Groups”.
“Admins” group is selected. ok ok ok

Observe the following rights
- “Admin”: Read, Update, Create, Delete
- “Data Entry Personel”: R, U C
- “Lab Workers”: R
- “Regular Data Entry”: R, U, C ok ok ok

Select “Person and Basic....” from left panel
and observe that the rights are as in “Start
Entry Here” ok ok ok

Select “Type of Desease” from left panel
and observe that the rights are as in “Start
Entry Here” ok ok ok

Select “Visit at Clinic” from left panel and
observe that the rights are as in “Start Entry
Here” ok ok ok

Select “Lab Results” from left panel and
observe the following rights:
- “Admin”: Read, Update, Create, Delete
- “Data Entry Personel”: R, U C
- “Lab Workers”: R, U, C
- “Regular Data Entry”: R, U, C ok ok ok

Close “Define Entry Rights” ok ok ok

Close project ok ok ok
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Open project “Clinical Example admin.epx”.
Use “translator” as login ok ok ok

Observe the following: ok ok

- variables, heading and sections can be
selected but not moved. ok ok ok

- new variables, heading and sections
cannot be added to the dataset. ok ok ok

- properties form for variables, heading and
sections is only viewable, nothing can be
edited. ok ok ok

- editing/adding valuelabels is not posible
(Valuelabel Edititor) ok ok ok

- Study information cannot be edited ok ok ok

- “Define Key” cannot be changed ok ok ok

- “Document” (menu) all items are greyed
out ok ok ok

- “Tool” (menu) all items are greyed out ok ok ok

Close project ok ok ok

Open project “Clinical Example admin.epx”.
Use “exporter” as login ok ok ok

Observe that same restrictions apply as
“translator”, except that “Export” tool is
working. ok ok ok

Close project ok ok ok

Open project “Clinical Example admin.epx”.
Use “pwadmin” as login

pwadmin får
programmet til at
crashe "svarer
ikke" ok ok

Observe that same restrictions apply as
“translator”, except that “User Access” ->
“Extended Access” -> “Manage User
Passwords” is enabled ok ok

Open “Manage User Passwords” and
observe that “admin” is greyed. ok ok

Double-click “admin” and observe that a
new window appear “User Properties”,
which cannot be edited. Click OK. ok ok

Double-click translator and observe that
“password” may be changed. Click OK. ok ok

Close “Manage User Password” and close
project ok ok

ok ok

Open project “Clinical Example admin.epx”.
Use “admin” as login ok ok ok

Save project as, using “File->Save Project
As” or use shortcut to a random filename. ok ok ok

Close project, and reopen newly saved
project. Use “admin” as login ok ok ok

Open “User Access” -> “Extended Access”
-> “Remove User/Group Administration”

kan ikke få lov at
fjerne det ok ok

Observe a warning windows will appear.
Click “Yes” ingen advarsel ok ok

Observe a second warning will appear. Click
“Ok” ok ok

Save project and reopen. Observe no
login/password is required. ok ok

Close project ok ok

Reports
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Task Linux Mac Win Win Notes

Tools
Task Linux Mac Win Win Notes

Sheet 2: EntryClient

EpiData EntryClient

Open/Save/Close
Task Linux Mac Win Notes

Open project “sample.epx” from “File->Open”

Open recent project “sample.epx” from “File->Open Recent->...”

Open project “sample.epx” with shortcut

Open recent project with shortcut

Open project “sample.epx” from “File->Open”

Save project using “File->Save Project”

Save project using shortcut

Close project

Preferences
Task Linux Mac Win Notes

Open preferences with Edit->Preferences

Close preferences

Open preferences with shortcut

Click all items on the treelist without other interaction

Print
Task Linux Mac Win Notes

Simple Data Entry
Task Linux Mac Win Notes
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Related Data Entry
Task Linux Mac Win Notes

Search
Task Linux Mac Win Notes

Misc.
Task Linux Mac Win Notes

Copy record to clipboard!

Default windows position

Help?

file:///tmp/lu32921gy43e.tmp/lu32921gy43y.tm...

15 of 15 2017-01-17 13:08


